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 1 Preamble
The GIMP is a very powerful tool for image editing and manipulation.  It is useful for digital
art, photography and a variety of other purposes.  It has a bewildering array of features, 
which can result in a steep learning curve.  GIMP is free, open-source software.  You can 
download in on Linux, Windows or Mac OS X and use it for any purposes at zero cost.

This Guide is intended to give a quick introduction to GIMP for common tasks that today's 
digital photographer needs to do.  The Guide starts with a “Quick Start” to familiarise you 
with basics of the GIMP user-interface.  This is followed by a “How to” section that gives 
step-by-step solutions to common needs of a photographer.  Subsequent sections delve into 
some of the depths of GIMP, to entice you to become an expert in GIMP.

 2 Quick Start
A GIMP image consists of 1 or more Layers on a Canvas.  Each Layer can be edited inde-
pendently, made (in)visible, various degrees of transparency, etc.  The final image is pro-
duced by flattening the layers.

GIMP features can generally be accessed in any of several ways (Fig. 1).  These include:

• The Menu bar at the top

• The Toolbox, usually at the left

• The Tool Dialogs, usually at the right

• <Right-click> context menu inside an image

• <Right-click> context menu inside a Dialog

• Keyboard shortcuts  Note: Use <Ctrl> on Linux and Windows, <Cmd> on MacOS X.

24th February 2018 GIMP Guide for Photographers 1

Fig. 1: GIMP windows



We now outline a few of the common menus and tools.  This list does not include many ad-
vanced features.

  Undo History

GIMP saves all edits in the History.  This is a powerful feature that allows you to freely ex-
periment without worrying that you may do lasting damage to an important image.

You can undo the last edit with <Ctrl-z> or Edit→Undo.  You can directly select any previ-
ous edit from the History Dialog.  <Ctrl-y> or Edit→Redo  moves forward in the edit His-
tory.  Thus you can go back and forth between edits freely, until you overwrite the image 
with File→Save. 

Note: the History is lost when you exit from GIMP.

  View Menu

Zoom in with + out with -

Zoom→Fit Image in Window makes the whole image visible

Zoom→1:1(100%) shows every pixel, useful for very fine editing

  Image <Right-click> Context Menu

View Exif: camera and exposure information

Image Properties: canvas size in pixels, file type, number of layers, etc.

Transform: Rotate, Flip

  Tools:

Toolbox <Ctrl-b>: selection, editing and other tools for quick access.  Hover the mouse 
over a tool to see its name.

Dialogs: A set of tabs such as Layers, Channels, Brushes, etc .  Each tab with options, 
lists, etc.  

Click and drag a tab outside the Dialog to undock it.
Click on the <left-arrow> icon at the right, then <Add Tab> to add a tab.

To get docked toolboxes: <Right-click>→Windows→Dockable Dialogs

<TAB> in image window: hide/show all docks

<Double-click> on a tool icon to open the tool options dialog tab

Manage Toolbox: You can customise the toolbox by adding/removing tools from it using 
Drag-and-drop.  Or use menu Preferences→Toolbox

Presets:  Many tools allow settings to be saved as presets and applied later.  To apply a 
preset, click on the <Preset> listbox at the top of the tool dialog.  To save the current 
settings as a new preset, click on the <+> icon.

Tip: If you have just used one of the Color tools, clicking on the image will reopen the 
Dialog for that tool.  
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  Selection

GIMP has a variety of ways of selecting part of an image.  This selection is used by many 
tools.  Tools for selection include constrained rectangular and elliptical regions, as well as 
freehand drawing.  The edges of the selection can be feathered to take care of fuzzy borders 
of an object.

Rectangle, ellipse, lasso (freehand), colour (magic wand).  Intelligent scissors is very 
useful for selecting irregular shapes.

<Shift-click> to add to current selection

<Ctrl-click> to subtract from current selection

<Shift-Ctrl-click> for intersection

Rectangle, ellipse: if has resize handles, resize or move selection outline

Without handles, move or copy the selected area

Quick Mask <Shift-q>: makes only current selection visible, useful for fine tuning the se-
lection.  Add or subtract from selection with any paint tool: Black subtracts, White 
adds.  Press <Shift-q> when done.

Copy selection: <Shift-Opt click-drag> on MacOS X to copy the selected are of the im-
age.  Note that a new “floating selection layer” is created.  Move or edit the floating 
layer.  When satisfied, click on the image to merge (anchor) the floating layer to the 
image, or press <Ctrl-h>. 
Key combination may vary on other systems, try <Ctrl-Alt>, <Shift-Ctrl>, etc.

Move selection: <Shift-Opt-Cmd click-drag> on MacOS X to move the selected area of 
the image.  Note that a new “floating selection layer” is created. 
Key combination may vary on other systems, try <Shift-Ctrl-Alt>, <Shift-Alt>, etc.

Copy/Move – alternate method: Sometimes the key-combinations above do not work.  
Copy/Move the selection using:

1. Copy/Cut the selection <Ctrl-c>/<Ctrl-x>
2. Clear the selection Select→None

3. Paste the selection <Ctrl-v>.  This creates a floating layer.
4. Use the Move tool to move the selection to the desired position.

5. Anchor the selection using <Ctrl-h> or Layer→Anchor Layer

 2.1 Useful Tips

This section contains tips that apply across many tools and features of GIMP.  They will 
help you become a more efficient and effective GIMPer.

1. Many tools operate on the current selection if it exists.  If there is no selection, the
tool operates on the active layer.  This can be confusing.  You may be able to con-
trol this behaviour using check boxes in the Tool Options.  Or, remove the selec-
tion using Select→None or <Shift-Ctrl-a>.

2. The Move tool operates on the active layer, or on some other layer if it is outside 
the image on the active layer.  The cursor has a hand pointer in addition to the 
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move symbol if it is over a non-active layer.  You can control this using check 
boxes in the Tool Options: “Pick a layer or guide” OR “Move the active layer”.

 3 Common Tasks – How To

 3.1 Crop an Image

Use the Rectangle Select tool to select the area for cropping.  Adjust the selected area using 
the handles in the corners.  Move the selected area by clicking in its middle.  Press <Enter> 
to confirm the selection.  In the Selection Dialog, you can fix the aspect ratio, the width, the 
height, or the size..  Or make other fine adjustments (see “ Selection” in Section  1 ).

When you are satisfied, click Image→Crop to Selection.  Note that the canvas gets resized 
to fit the cropped image.

The Ellipse selection tool is useful to get a photo frame effect.

 3.2 Scale or resize an image

Digital cameras nowadays with 20-25 megapixel sensors produce large images, such as 
6,000 x 4,000.  For a webpage or a document, you may want to scale the image to say 1,200 
x 800.  This is easy in GIMP:

1. File→Open the image

2. Image→Scale Image to bring up a dialog.  Be sure that the chain to the right is con-
tinuous to preserve the aspect ratio.  Enter the desired width or height.  You can se-
lect the units of size as pixels or percent.  Eg above, specify the width as 1,200 
pixels, or as 20%.  If the aspect ratio link is on, the height will be set automatically.

OR

Pick the Scale tool and click on the image, then use the handle in a corner to scale 
the image (or scale the selection).  As above, use the dialog to preserve aspect ratio..

An image out of the camera may occupy 5-15 MB.  For webpages and email, it is necessary 
that the file size be reduced to a few 100 KB.  This can be controlled via a combination of 
scaling and reduced JPG quality.

1. Scale the image as above

2. Save the file with File→Export As  and select file type such as JPG or PNG.
3. When saving as JPG, move the Quality slider to lower values to get smaller file 

sizes:

a. 100: best quality, largest file, say F MB
b. 90: almost best quality, file about F/3 MB

c. 65-85: good quality, file about F/6 MB
d. 40-60: acceptable quality, file about F/8 MB

Note: reduction in file size is dependant on the contents of the image.
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 3.3 Automatic exposure and colour

For quick adjustments, try the auto col-
our tools, Equalise, White Balance, 
Color Enhance, Normalize, Stretch
Contrast, and Stretch HSV (Fig. 2).

These scale the histograms of the 3
primary colours in various ways.  The
effect of each tool depends on the im-
age.  Try them all to achieve the de-
sired effect.

If these are not satisfactory, see Sub-
sections  3.4  and  3.5  below for manu-
al methods that give you more control.

 3.4 Correct the exposure of
an image

 3.4.1 Quick Method

Use Colors→Brightness-Contrast.  
In the pop-up dialog, adjust the
sliders.  Applies to the current selection even if it is in an inactive layer.  If no selec-
tion, applies to the active layer.

For visual operation, click and drag mouse from the centre of the image to operate the 
sliders:  up/down ==> +/- brightness, left/right ==> +/- contrast.

 3.4.2 Fine control by colour

Use Colors→Levels.
Automatic level setting: Click <Auto>

Manual setting:

1. Select Channel: Value for intensity of all colours.  Or select one of the Channels 
Red, Green or Blue

2. In “Input Levels”

◦ move the left slider to the black point (all pixels less intense than this will ap-
pear pure black)

◦ move the right slider to the white point (all pixels more intense than this will 
appear pure white)

◦ move the centre slider to the middle-grey value.  Moving to the left brightens 
shadows.

You can set the 3 levels by entering numeric values in the range 0-255.  Black, grey and 
white points can be selected from the image using the eye-droppers.

To view the histogram of the image, use Colors→Info→Histogram.  Select “Value”, 
“Red”, “Blue” or “Green”.

24th February 2018 GIMP Guide for Photographers 5

Fig. 2: The Colors→Auto Tools



 3.4.3 Backlit subject

When you take photos of people outdoors with bright sunlight from the back, the camera 
sets the exposure for the whole scene, and subjects' faces in shadow are underexposed.  If 
you increase the exposure of the whole image so that the faces are properly exposed, the rest
of the scene gets overexposed.

Use GIMP to increase the exposure of only the shadows in the image.  

1.  Use Colors→Levels.  Notice in the histogram that there is a zero level segment at 
the left and right ends.  

2. Select Channel: Value 

3. In Input Levels, move the left (black level) and right (white level) sliders inwards 
until the zero level segments are excluded

4. Move the centre (grey level) slider towards the left to increase the exposure of the 
shadows.

This method also increases the brightness of the overall scene.  In case you wish to leave the
scene as-is and only enhance the shaded object:

1. Select the shaded object (see “ Selection” in Section  1 ).

2. Now, use Colors→Levels as above.  The sliders will only affect the selection.

The bulbul in Fig. 3 was shot facing towards the bright early morning sky.  The camera ex-
posed for the sky, so the bird is too dark (a).  The image in (b) is auto enhanced with Levels.
The details of the bird are still obscured.  In (c), with manual adjustment of levels, the de-
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     (a)         (b)

     (c)        (d)

Fig. 3: The bright morning sky was behind the bulbul.  (a) Camera exposure (b) GIMP
Levels auto (c) Levels with manual adjustment (d) Levels with manual adjustment restric-

ted to the bulbul.  



tails of the bulbul's eye and feather colours are visible.  Image (d) is similar to (c) except that
the level adjustments were applied only to the selected bird.  Hence, it stands out from the 
background sky more clearly.

 3.5 Correct the white-balance of an image

Basic corrections:  Use Colors→Levels.

1. Select Channel: “Red”, “Blue” or “Green” to correct a specific colour.

2. In “Input Levels”

◦ move the left slider to the black point (all pixels less intense than this will ap-
pear black)

◦ move the right slider to the white point (all pixels less intense than this will 
appear white)

◦ move the centre slider to the middle-grey value
You can set the 3 levels by entering numeric values in the range 0-255.  Black, grey and 

white points can be selected from the image using the eye-droppers.
Fine-tuning: Use Colors→Color Balance

1. Select Range “Shadows”, “Midtones” or “Highlights” to adjust
2. Adjust the 3 sliders to correct the colour cast

Note: Check “Preserve luminosity” to preserve the average image intensity.
For very fine adjustments, try Colors→Curves

 3.6 Convert to black-and-white

Use Colors→Colorize
Set “Saturation” to 0 for greyscale image

For a colour tone, eg. sepia, set “Saturation” to a mid-value and choose the colour using 
the “Hue” 360-degree colour wheel.

Alternatively, use Colors→Desaturate.  You can select grey levels dependant on the 
lightness, luminosity, or an average of both.

 3.7 Combine 2 or more images side-by-side

1. File→New In the dialog, set canvas of sufficient size to hold the combined images.  
Use Image→Image Properties to find out the size of each image

2. File→Open as layers — select all the images in the file dialog.  Each is opened in a 
new layer.

3. Select a layer, then use the Move tool to move the image to its desired position. 
Scale the layer image using Layer→Scale Layer if needed.

4. Repeat Step 3 with each layer.
5. Once all images are scaled and positioned as desired, draw a rectangular selection 

box that exactly includes all images, then Image→Fit Canvas to Selection.

6. Save the image as .xcf for future editing, and export as .jpg
Caution: Image→Crop to Selection and Image→Scale crops/scales all layers.
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 3.7.1 Make a collage

Combine several images as above.  Create a background layer at the bottom of the layer 
stack and fill it with a suitable colour or pattern using the Bucket Fill tool or Blend tool.  Im-
ages in different layers can overlap one another as desired.  Use the Rotate tool to position 
an image at an angle.  Change the order of images in the layer stack to get the desired effect. 

 3.8 Blend 2 images

You have two images.  One has a well-defined object that you want to appear in the middle 
of or to one side of the other image.  For instance, you have a picture of a person and anoth-
er picture of a scenic river.  You want the person to appear by the side of the river.  You 
have a picture of a building and another of a mountain range.  You want the building to ap-
pear at the base of the mountains.

1. Open both images in layers, move the object image lower in the stack (Section  3.7 )
2. In the top image, select the region in which the object from the other image is to ap-

pear.  If necessary, scale the lower image using the Scale tool (see Subsection  3.2 ).

3. Select→Invert.  For blurred edges, Select→Feather, choose say 50 pixels
4. Layer→Add Layer Mask: check Selection.  The other image appears in the selection 

window.

5. Edit the layer mask to adjust the window.
Alternate method to get a more gradual transition between the images:

1. Open both images in layers, move the object image lower in the stack (Section  3.7 ) 

2. Select the layer with the top image and click Layer→Add Layer Mask: check 
White(full opacity)

3. Using the Rectangle or Ellipse tool, select the area on the mask where you want the 
other image to appear (see “ Selection” in Section  1 ).

4. <Double-click> the Blend tool.  In the Tools Options, select Gradient “FG to trans-
parent”, select Shape “Square” or “Radial” to match the selection shape.  

5. Make sure that FG/BG colours in the Toolbox are Black/white.

6. Drag the Blend tool from the centre of the selection outwards.  Short drag => small 
transparent region in centre with quick transition to opacity; long drag => more of 
the selection is transparent with a gentle gradient to full opacity.

A quick method, though less flexible, is to cut the object from one image and paste it on the 
other image.  The pasted object is in a floating layer and can be moved, scaled, flipped, etc.  
After pasting is done, the object become a part of the base image and cannot be separated.

1. Select the object from one image (see “ Selection” in Section  1 ).

2. Select the layer with the base image, clear the selection Select→None, and 
Edit→Paste.  

3. A floating layer is created with the pasted object.  You can edit and move this until 
satisfied.

4. Click on the base image to merge the floating layer into the base image.  Or, use 
Layer→Anchor Layer.
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 3.9 Correct perspective of tall buildings

When you take a picture of a tall build-
ing from close by, you have to tilt the
camera upwards.  In the picture, the
building appears to lean backwards.
With GIMP it is easy to correct the per-
spective.  See Fig. 4 for example.

1. Open the image
2. Select the Perspective Tool.  In

the Tool Options, if the building
is leaning backwards, check
“Corrective (backwards)”.  Se-
lect Clipping “Crop to Result”.
Select Guides to get a reason-
able number of grid lines.

3. Click in the image.  The grid ap-
pears and also the Transform
dialog.  Move the dialog off the
image.

4. Use the 4 corner handles to ad-
just the image until the vertical lines of the building are almost parallel to the 
guidelines.  Similarly, correct any horizontal perspective.
Note: Leave a little perspective so that the building does not look unnatural.  

5. Press <Enter> to Transform the image.
6. If the image appears distorted, correct the aspect ratio, using the Scale Tool.

 3.10 Clean sensor or lens dirt

A speck of dust or a fingerprint on the
lens, or dirt on the sensor results in a
blurred spot on the image.  If this spot
appears in a plane area such as the sky,
it may be quite noticeable.  Such spots
can be removed with GIMP's Smudge
Tool (the pointing index finger icon in
the Toolbox).  Rub the spot repeatedly
with the Smudge Tool.  This blends the
colours in the pixels that are smudged.
Smudging is akin to rubbing a watercol-
our painting with a wet finger.  It re-
duces the intensity of the spot, but does
not entirely eliminate it.  This tool is
easy to use and the image is not obvi-
ously edited.
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Fig. 4: The picture on the left of the Basilica in
Goa was taken with a 10mm wide-angle lens.

On the right is the perspective-corrected picture,
with a little vertical perspective retained to give

an impression of the height.

Dark spots on light background

Fig. 5: Spots removed using
smudge tool (left) and clone tool (right)



Note: You can select the brush size and various effects in the Tool Options.  However, the 
brush colour setting has no effect.

A more powerful alternative is the Clone Tool.  With this, you first select a part of the sky 
without the spot, then apply this selection over the spot.  The spot is completely replaced.  
However, unless used skilfully, the Clone Tool is likely to leave visible edges.  

See Fig. 5 for use of the smudge and clone tools on a green image with dark green spots.  
Smudging leaves slight traces of the dark spot, while cloning completely removes the spot.

 4 Layers
A GIMP image consists of a stack of semi-transparent sheets or layers placed onto of a can-
vas.  You view the image by looking through the stack of layers from the top layer to the 
bottom layer (top to bottom order in the Layer Dialog).  What you see is a merged view, de-
pending on the visibility and transparency of each layer.

You can change transparency of each layer, change the order of layers, make a layer tempor-
arily invisible.  Edits on one layer do not affect other layers in any way, except that the im-
age on one layer may partially or wholly obscure lower layers.  

Use of new layers ensures that the original image is unaffected.  This enables you to freely 
experiment until you have achieved the desired effect.  If you make a mistake, simply delete 
the new layers!  Any editing except for very trivial changes is best done by use of layers.  It 
is common to have many layers in your image during editing.

If you wish to draw boxes, ovals, etc on top of an image, create a separate layer for your 
drawings.  To annotate an image with text, create a separate text layer.  To change the opa-
city of a layer, select the layer in the Layer Dialog and adjust the Opacity slider between 0% 
(fully transparent) to 100% (fully opaque) at the top of the dialog.

When you save the image, say DSC1234.jpg, GIMP saves the image with all layers sep-
arately in the file DSC1234.xcf.  The special format .xcf is not useable by most photo 
viewers, browsers, etc.  When you are done editing and want to use the image elsewhere, ex-
port to JPG or other standard image format.  Exporting flattens all the layers into one.

The Layers menu, or <Right-Click>→Layer in the image, or <Right-Click> in the Layer 
Dialog pops up a menu with assorted functions such as create/delete a layer, transform the 
layer by rotation/flipping, merge 2 layers, set transparency, etc.

 4.1 Example use of layers

Suppose you wish to edit one feature in an image, say make change the colour of a cloud: 

1. Select the part of the image that you wish to edit

2. Copy to the Clipboard with <Ctrl-v> or Edit→Copy
3. Make a new layer from the selection using Edit→Paste as→New Layer

4. Select the new layer in the Layers Dialog.  Drag it to the top of the stack.
5. You can now move the selection, edit it, crop it, etc.  For clarity, you may make a 

layer invisible by clicking on the <Eye> icon in the Layers Dialog.  <Shift-Eye> 
makes all other layers invisible.
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6. When you are satisfied, save the image using File→Export.  The visible layers are 
flattened and saved in the desired format, such as .jpg, .png, etc.

 4.2 Layer mask

Each layer can have a mask to set the transparency of the layer.  Unlike the opacity slider 
which applies uniformly to the entire layer, the layer mask can be used for selective trans-
parency.  The degree of transparency is set by the colour of the mask which can range from 
white through shades of grey to black.  

• If an area of the mask is white, the layer is fully opaque.  The lower layers are fully 
obscured.  The area can range from 1 pixel to the whole image.

• If an area is black, the layer is fully transparent.  The lower layers are fully visible 
and the current layer is not visible.

• If an area is grey, the layer is partially transparent.  The transparency and intensity of
the current layer is reduced in inverse proportion to the greyness.

Use items in the <Right-Click>→Layer→Mask menu to:

Add a mask:  Initialise the mask to white (full opacity), black (full transparency), the cur-
rent selection, etc.  A layer can have only 1 mask. 

Edit the mask:  First click on Show Mask to make it visible for editing.  Then edit using 
any paint tool with brush colour set to black, shades of grey or white.  Use the Blend 
Tool to get a graduated transparency across the image.  When you are done editing, 
uncheck Edit Mask and Show Mask so that you can edit the image on the layer. 

Disable the mask: temporarily disable the mask without deleting it.

 5 Delving Deeper
This tutorial has covered some of the commonly used features and essential aspects of 
GIMP.  You should be able to do many tasks with GIMP now.

GIMP is a very powerful image editor.  Each of the features described in the preceding sec-
tions has many more bells and whistles.  GIMP has numerous other features and capabilities.
Read the GIMP Manual (available under the Help menu or by pressing <F1>) and experi-
ment to become an expert with GIMP.

In this Section, we touch on a few other capabilities of GIMP.  These include filters, chan-
nels, paths, batch processing, and scripting to automate tasks.  

 5.1 Special effects

GIMP has many filters to achieve special effects, in the Filter menu.  Color→Posterize re-
duces the number of colours in an image to make it look like a map.

 5.2 Channels

There are two types of channels: Colour Channels and Selection Masks.
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 5.2.1 Colour Channels

There are 3 colour channels: Red, Green and Blue.  A colour channel includes all pixels of 
the specified colour in the entire images, across all layers.  The Alpha channel is a colour 
channel for advanced usage.  In the Channels Dialog, if you make Green and Blue invisible, 
you will see your image as shades of red.  With Red and Green visible, the image appears in 
different shades of yellow.

 5.2.2 Selection Masks

<<< to be added >>>

 5.3 Paths

<<< to be added >>>

 5.4 Batch processing

You have taken a bunch of pictures of a function held in a pandal.  All the images have a 
similar colour cast due to the colour of the tent.  You laboriously correct the colour balance 
of one image (see Section  3.5 ).

You have a large number of images taken with a 25 MP digital camera, each of file size 8-15
MB.  You want to resize each image to about 200-500 KB for posting on a website.  You 
know how to manually resize each image (see Section  3.2 ).

BIMP, a batch processing plugin for GIMP, allows you to quickly repeat the same correc-
tions on all the images in such cases.

 5.5 Scripting

If the builtin features do not meet your needs, GIMP is extensible via several scripting lan-
guages.  These include Script-Fu (a variant of Scheme) and Python-Fu.  By writing a script, 
you can add a new editing feature, or combine a series of editing steps into one.  For those 
who are not programmers, the plugin repository at http://registry.gimp.org/glossary/a con-
tains a number of useful scripts. 

 5.6 Customising GIMP

GIMP can be customised to your taste.  You can tailor many Preferences, Keyboard Short-
cuts, Modules, and measurement Units.  These can be accessed via the main menu, or via the
<Right-click>→Edit image context menu. 
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